1984 Spree Tail Light, horn, and turn signals wont turn off

This is the place to discuss your build with other builders and solicit feedback and help with parts of your build: engine, body work, bolt ons, etc.

Moderator: Moderator

Post Reply
TheJoker13
Noob
Noob
Posts: 2
Joined: Tue Jun 27, 2017 11:58 am
Location: NY

1984 Spree Tail Light, horn, and turn signals wont turn off

Post by TheJoker13 » Tue Jun 27, 2017 12:13 pm

I turn off my 1984 honda spree model NQ50 and the tail light, horn and turn signals still work. i dont know where the problem is occuring. ive check most of the wiring but i honestly dont know what it could be
1984 Honda Spree (The Joker)

User avatar
Meatball
CB900F
CB900F
Posts: 1713
Joined: Sat Jun 04, 2016 10:45 am
Location: seattle

Re: 1984 Spree Tail Light, horn, and turn signals wont turn

Post by Meatball » Tue Jun 27, 2017 12:25 pm

Ignition is either faulty or installed incorrectly. Check the connections and refer to the Service Manual for proper installation.
I need to find some new haters...the ones I have are starting to like me.

TheJoker13
Noob
Noob
Posts: 2
Joined: Tue Jun 27, 2017 11:58 am
Location: NY

Re: 1984 Spree Tail Light, horn, and turn signals wont turn

Post by TheJoker13 » Tue Jun 27, 2017 12:35 pm

um haha i already regret saying this but where is that? i literally bought it and just got it to my house today. i have no mechanical experience .. besides on my truck
1984 Honda Spree (The Joker)

kevinv710
Spree
Spree
Posts: 243
Joined: Fri Jul 12, 2013 2:03 pm
Location: Seattle

Re: 1984 Spree Tail Light, horn, and turn signals wont turn

Post by kevinv710 » Tue Jun 27, 2017 12:53 pm

download a Honda Spree service manual, read on chapter 14 and 15, you will have a piece of mind how the electrical system works, specially on "Ignition switch" .......with key OFF, but scooter acting as ON position, which means BAT1(Black) and BAT2(Red) has no cut off......you may remove a small plastic front cover to double check on those ignition switch connections, you may found some wrong connections hooked up or some dirty subject that accidently connecting to others, time to clean it up and re-connect them..... remove battery, spray some carb cleaner into ignition switch, turns key all the way left, all the way right several times, one more time...then blow some air in there to clears up all dirt out....re-intall battery and test it, should be ok by now, if the problem is fixed, add 2 drops of wd40 into ignition switch to keep it lubricated. Hope this helps...!

kevinv710
Spree
Spree
Posts: 243
Joined: Fri Jul 12, 2013 2:03 pm
Location: Seattle

Re: 1984 Spree Tail Light, horn, and turn signals wont turn

Post by kevinv710 » Tue Jun 27, 2017 12:57 pm

TheJoker13 wrote:um haha i already regret saying this but where is that? i literally bought it and just got it to my house today. i have no mechanical experience .. besides on my truck
here they are
http://motorscooterguide.net/Downloads/Downloads.html

User avatar
Meatball
CB900F
CB900F
Posts: 1713
Joined: Sat Jun 04, 2016 10:45 am
Location: seattle

Re: 1984 Spree Tail Light, horn, and turn signals wont turn

Post by Meatball » Tue Jun 27, 2017 1:11 pm

TheJoker13 wrote: where is that?
Where the key goes in. Take off the front plastic cover to expose it to see. Check if its wired funky. There is 4 wires that are color coded coming from it. They should be connected to the bike's wiring harness to the correct colors. Either with a plug connection or some other means. Colors MUST match and ALL wires must be connected.
I need to find some new haters...the ones I have are starting to like me.

Post Reply