1985 Honda Elite 80

Trying to get your Spree/Elite to run, or run better? Post your questions here.

Moderator: Moderator

Post Reply
BM3216
Noob
Noob
Posts: 2
Joined: Sun Aug 02, 2020 5:11 pm

1985 Honda Elite 80

Post by BM3216 » Tue Aug 04, 2020 9:28 pm

I have a problem with my Honda Elite 80. It starts fine then after I drive a mile or so at full throttle it’s looses power as if it looses fuel. I have a new carburetor. New fuel tank valve and new spark plug. After it looses power and stalls it’s hard to restart. Anyone else experience this?

User avatar
motormike
Moderator
Moderator
Posts: 4981
Joined: Wed Dec 29, 2010 10:58 pm
Location: Nashville, TN.

Re: 1985 Honda Elite 80

Post by motormike » Wed Aug 05, 2020 12:28 am

Yes, have experienced this...typically, you need to check and clean the tank of rust and debris, replace old fuel and vacuum hoses.
Install a fuel filter.
You are losing fuel delivery.
Old hoses can deteriorate inside, swell shut, and introduce debris into the carb.
Float and needle can malfunction, usually caused by debris and rust.
At least remove the float bowl and check for debris.
I have had good luck with the Elite 80 replacement carbs from ebay for $59.95
Vacuum hoses are critical to the operation of fuel petcock.
No vacuum = No fuel
RideRed
OH-ARRR Racing
#53 Gyro

<Hondas>
<Gyro S><Helix><XL75><NN50M Gyro><NU50 Urban>
..Trooper...Buzby...Jon-Boy...Blooper
Yamahas'93 Jog><'13 Majesty><RD60>

"Live Large - Ride Small"

BM3216
Noob
Noob
Posts: 2
Joined: Sun Aug 02, 2020 5:11 pm

Re: 1985 Honda Elite 80

Post by BM3216 » Sun Aug 09, 2020 3:50 pm

Thank you I will give that a try

Post Reply