I am stumped... Suzuki FA50 problems please help

Need help with your non-Honda scooter? Yamaha, etc? Post here!

Moderator: Moderator

User avatar
Wheelman-111
Moderator
Moderator
Posts: 11028
Joined: Wed Oct 22, 2008 5:09 pm
Location: Deepinnaharta, Texas

Re: I am stumped... Suzuki FA50 problems please help

Post by Wheelman-111 » Thu May 24, 2018 9:03 am

Greetings:

Yes, there's likely an oily mess if a seal is weak at high RPM. By no means is this the only possibility. Obstructions to high flow that don't affect idle and low-speed operation can include intake, carb fuel obstructions - even a fuel filter - and exhaust crud. Another hunch based on personal experience; if there's a vacuum-operated fuel valve of any sort, make sure it doesn't close when throttle is wide open. Good luck.
Wheelman-111
Most of my money is spent on scooterparts. The rest is just wasted.
Still Seeking Red PCX-150
Flash 9: 2001 Elite SR Contesta 72 ZX Tran, 9:1 Gears, Stock Airbox, Carb and Pipe 58.8 MPH
Punkin: 2010 Vespa/Malossi S78, 99KPH

:coolcruise:

kingdele
BMX
BMX
Posts: 47
Joined: Tue Mar 20, 2018 1:14 pm
Location: Wisconsin

Re: I am stumped... Suzuki FA50 problems please help

Post by kingdele » Fri May 25, 2018 10:46 am

Wheelman-111 wrote:Greetings:

Yes, there's likely an oily mess if a seal is weak at high RPM. By no means is this the only possibility. Obstructions to high flow that don't affect idle and low-speed operation can include intake, carb fuel obstructions - even a fuel filter - and exhaust crud. Another hunch based on personal experience; if there's a vacuum-operated fuel valve of any sort, make sure it doesn't close when throttle is wide open. Good luck.
There is no leakage of any kind coming from the engine, I have a new and extremely clean carb and the exhaust is unclogged. The fuel valve is one that only flows when engine is running but does have a ÔÇ£primeÔÇØ position which lets the gas flow when it isnÔÇÖt running and that position doesnÔÇÖt change the problem.

User avatar
noiseguy
Site Admin
Site Admin
Posts: 4313
Joined: Sat Jul 31, 2004 8:00 pm
Location: South Florida
Contact:

Re: I am stumped... Suzuki FA50 problems please help

Post by noiseguy » Fri May 25, 2018 2:27 pm

So we're back to electrical issue and main jetting.

- Did you check the plug wire and cap? On some caps, the underside of cap (that attaches to plug) has a metal part that unscrews... contains a resistor, and can corrode. Again, quick to check. Any sort of corrosion on these parts can create a sort of low-pass filter that keeps the engine from running at higher RPMs while not impacting idle.

- Do you have a larger main jet you can install to see if this clears up issue? Something 5 - 10 pts higher than current? Or an extra jet you can drill out to next size up? What you describe sounds like extreme lean bog at higher RPMs.

- You have the factory airbox and element... right? B/c that will cause lean bog as well. Just looked at the factory filter box... looks like a foam insert. Did you check it for rot?

Past that, agree carb is probably clean or it wouldn't idle. Reed valves would impact idle / mid-range, likewise air leaks. I'll take your word for clean exhaust, and assume you checked the exhaust port for plugging.
Admin, Hondaspree.net

Buy new air filters and gasket kits here (Ebay): http://stores.ebay.com/noiseguysstore
Buy new air filters and gasket kits here (Amazon): www.amazon.com/shops/spreepower

Post Reply