New kit low compression

Trying to get your Spree/Elite to run, or run better? Post your questions here.

Moderator: Moderator

Post Reply
nhscooterguy
Noob
Noob
Posts: 10
Joined: Tue Aug 18, 2020 3:21 pm

New kit low compression

Post by nhscooterguy »

Hi guys,

I'm at my wits end with this issue.

It's a 94 Elite SA50P. I'm getting compression around 80 or 90 PSI on a new 82cc NYC kit from scooter swap shop. It was around 110 when I first installed it but has since gotten lower. New rings, head, gaskets, piston and jug. I just did the crank seals as well. 24mm PWK carb with a new intake, uni filter, and a new exhaust.

The engine fires like it's going to start and gets noticeably warmer after trying to start but it won't catch and stay running. Everything seems to be sealed up right around the base and head gasket. It's definitely getting fuel. I also replaced the vacuum line because it looked rough. It has spark.


Any thoughts on the low PSI? is the kit just junk?
User avatar
vintagegarage
Elite
Elite
Posts: 761
Joined: Tue Jun 23, 2015 7:03 pm
Location: Florida

Re: New kit low compression

Post by vintagegarage »

1. How well did the engine run before you put the 82cc kit on it?

2. Poor compression can also be caused by bad crank seals. I see you installed crank seals.. did the installation go well, or were either of them damaged in installation?

3. When you take the uni filter off, and cover the intake to the carb with the palm of your hand, and hit the starter button, what happens?

4. What is the throttle position when you try to start it?

5. Does turning the idle adjustment screw in one full turn make any difference? Looking into the carb intake, can you see the slide rise when you turn in the idle adjustment screw?
nhscooterguy
Noob
Noob
Posts: 10
Joined: Tue Aug 18, 2020 3:21 pm

Re: New kit low compression

Post by nhscooterguy »

It ran ok until the top end blew. Previously I installed a Malossi kit. After riding it hard one day I lost power down a hill then it wouldn't start. I had like 30psi so I pulled the jug and it was all scored. Operating temp was about 250 Fahrenheit when it died. The whole long ride it never got over 260.

So I bought the NCY kit from scooter swap shop and threw it on to replace the Malossi 72cc kit.

When I cover up the filter side of the carb it still doesn't start... I noticed my spark plug had gas on it though.

I've tried starting it with closed and open throttle and with/ without choke.

The crank seals look good. I installed them brand new and very carefully by gently tapping them with a socket slightly smaller in diameter.

The slide does rise when I turn the screw.

Thank you for your time and your help
User avatar
vintagegarage
Elite
Elite
Posts: 761
Joined: Tue Jun 23, 2015 7:03 pm
Location: Florida

Re: New kit low compression

Post by vintagegarage »

I appreciate your answers.. anyone else have any ideas for nhscooterguy?
nhscooterguy
Noob
Noob
Posts: 10
Joined: Tue Aug 18, 2020 3:21 pm

Re: New kit low compression

Post by nhscooterguy »

Thanks vintagegarage... I still haven't figured out out...
Post Reply