1985 Spree starts and runs but won’t idle at all only runs at half to full throttle

Trying to get your Spree/Elite to run, or run better? Post your questions here.

Moderator: Moderator

Post Reply
Harsh
Noob
Noob
Posts: 2
Joined: Mon Jun 14, 2021 9:05 pm

1985 Spree starts and runs but won’t idle at all only runs at half to full throttle

Post by Harsh »

I just picked up a 85 spree and I changed out the spark plug, new oil, fresh gas, and the petcock was bad so I replaced that as well. Now it starts and runs I drove it around for a while too but when I do start it I need to keep it above half throttle at all times or it Boggs down any advice? Thanks
Harsh
Noob
Noob
Posts: 2
Joined: Mon Jun 14, 2021 9:05 pm

Re: 1985 Spree starts and runs but won’t idle at all only runs at half to full throttle

Post by Harsh »

Also I’m new to this kind of stuff it’s my first scooter so if you could dumb down the answer that would be greatly appreciated.
User avatar
motormike
Moderator
Moderator
Posts: 5117
Joined: Wed Dec 29, 2010 10:58 pm
Location: Nashville, TN.

Re: 1985 Spree starts and runs but won’t idle at all only runs at half to full throttle

Post by motormike »

The carburetor needs to be cleaned, especially the "pilot circuit" in order to idle properly.
This is the most likely thing giving you a problem.
There are always other things that could be contributing, but pilot jet and cold-start enrichment circuit are primary suspects.
RideRed
OH-ARRR Racing
#53 Gyro

<Hondas>
<Gyro S><Helix><XL75><NN50M Gyro><NS50f><NU50 Urban>
..Trooper...Buzby...Jon-Boy...Blooper
Yamahas<'13 Majesty><RD60>

"Live Large - Ride Small"
Post Reply